Troubles in Maple Pro 6 (bugs)

Questions regarding Maple, Maple Professional, and Maple Reader

Troubles in Maple Pro 6 (bugs)

Postby Miguel » Tue Aug 23, 2005 5:56 pm

Hello

I´ve instaled the latest version available today (6.0) and started changing a file created in 5.2 after converted it to the new 6.0 format.
This file has a root folder with several items (nodes) inside it, each one with some text content only.
Since i need to organize those items (nodes) in categories i´ve created several more nodes (let´s call them "folders" so you can understand better whats´s going on) on the root and start moving all my items (nodes) to inside those new "folders" on the root.
The problem is that this new version seems buggy. When moving my items (nodes) to inside those new created folders Maple sometimes add the content(on the right panel) of one of the items to the folders inself (on the right panel) and other times it duplicated an entire existing branch of items that i already moved to a folder to inside some of my items..

I have tried to organize that file several times carefully moving the items so i have sure that i wasn´t screwing up things, but there´s no way. Maple 6.0 screws up all the organization adding and duplicating contents in several places (nodes)...

Just for info the original file i´m trying to organize has one node at the root with just 28 items inside, each one with a text description with 50 lines of text. Nothing really complicated..


Best regards,
Miguel
Miguel
 

Postby support » Wed Aug 24, 2005 8:53 am

To fix this problem, please uninstall your current Maple Pro 6.0 installation and download the latest version from our web site. Although it has the same version number, there are some minor chages in it. Then open your tree, click the root node and select File\Export\Branch. You will get a fixed .mpl file.
support
Site Admin
 
Posts: 317
Joined: Tue Aug 31, 2004 8:59 am

version 6.0 buggy

Postby Miguel » Wed Aug 24, 2005 1:56 pm

Thanks for your quick reply.
Unfortunately it doesn´t solved the problem. In fact i´ve discovered a few more bugs, and strange behaviors.

I´ve downloaded the latest version from your site as you said and tried reorganize my file again. The same problem persist. I exported the root branch as you said but the resulting file is even worse with more of my items content added in several places/nodes. It screwed up the organization of the nodes.

So i decided to pick the original file again and tried to very very carefully organize the structure of the nodes as i described in my first post. After some manual corrections to delete the contents that Maple adds to the nodes, i got the organization i wanted. So i saved the file, closed Maple and opened the file again to check if everything was still there. But two of the new nodes (folders) i created have lost their names and appeared empty. I tried to rename these to folders again and this is the error message i got:

Dataset not in edit or insert mode - Native error:10007.

The program DIDN´T crashed and changed the name of the folders as i wanted but added some branches of other folders content again in several places/nodes and everything got screwed up again.

Right now i cant´s rely on Maple 6 to organize my data and reinstaled my 5.3 version again.
I would like to help to fix all those bugs and problems because i like this program a lot. I can send you my original file and a text description of my steps so you can recreate the problem if needed. Just let me know...

Thank you for your attention,
Miguel
Miguel
 

Postby Miguel B. » Wed Aug 24, 2005 3:11 pm

After some tests with a new test file created with Maple 6 version, i decided to reconstruct my old 5.3 maple file with the new Maple 6 from scratch. Seems that files created with Maple 6 from begining don´t have the problems i have explained in my first post. Only converted files from previous versions seems problematic. So i assume that´s the conversion between 5.3 and 6 versions that is causing all this trouble.

For now my newly created file in Maple 6 seems working fine when i move and reorganize nodes.
Miguel B.
 
Posts: 7
Joined: Mon Sep 13, 2004 5:49 pm

Postby support » Fri May 21, 2010 7:12 pm

The method described above creates brand new file in native Maple 6.0 format. It fix all problems that may cause conversion.


Last bumped by Anonymous on Fri May 21, 2010 7:12 pm.
support
Site Admin
 
Posts: 317
Joined: Tue Aug 31, 2004 8:59 am


Return to Maple

Who is online

Users browsing this forum: No registered users and 1 guest

cron