Disabling alt+tab

Post a reply


In an effort to prevent automatic submissions, we require that you type the text displayed into the field underneath.
Smilies
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is OFF
Smilies are ON

Topic review
   

If you wish to attach one or more files enter the details below.

Expand view Topic review: Disabling alt+tab

Disabling alt+tab

Post by JerryA » Sun Sep 03, 2006 4:51 am

We're having a security issue with WinLock on a public access computer.

The task manager is disabled under the security program - that is good. The
keyboard task switching (alt-tab) function is not disabled however - so the minimized tasks can be brought back using alt-tab.

So here's the scenario:


I fired up an email session, minimized it (and it disappeared as expected). Then started another session, logged onto my email account again and then logged off. Then I reactivated the minimized session and lo and behold there was my email session. However one can't do much with it (I didn't experiment very much). When I tried to logoff again I got a session error for an invalid cookie. So it is
reasonably secure if I assume I will get this message for other things I try to do but obviously the security is in the hands of whatever web service you were using. Also, for example, if I was in the middle of reading an email when I minimized it, all of that is brought back for whomever to see (think banking information for something that might be more sensitive to people).

Can you suggest a WinLock setting that will address this issue?

Thanks.

Jerry

Top